summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 17:54:45 +0800
committerSukanka2022-06-06 17:54:45 +0800
commit0d74410cfdbfb51fecefc1c508fe901feafae4e7 (patch)
tree2eeacb182a903c8f598615c0ca13a3ccb589ed47 /PKGBUILD
downloadaur-0d74410cfdbfb51fecefc1c508fe901feafae4e7.tar.gz
add r-panvizgenerator
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7afb4c7722dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=PanVizGenerator
+_pkgver=1.22.0
+pkgname=r-${_pkgname,,}
+pkgver=1.22.0
+pkgrel=2
+pkgdesc='Generate PanViz visualisations from your pangenome'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-findmyfriends
+ r-igraph
+ r-jsonlite
+ r-pcamethods
+ r-shiny
+)
+optdepends=(
+ r-biocstyle
+ r-digest
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('4d0ccdf162d78f8bf7bc676862b104b61c401682d999b001a02bb15998141d66')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: