summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Fink2023-03-26 20:39:00 +0300
committerChristoph Fink2023-03-26 20:39:00 +0300
commit5e90bb5b776d9d7e09b470646b21d53e6a717b84 (patch)
treee11ae7862c5decbd918e1ee76c88d80592a7def8 /PKGBUILD
parent2fb2e7827aa1ad57b7dcf918734f968b5362c33b (diff)
downloadaur-r-pillar.tar.gz
upgpkg: r-pillar 1.9.0-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 28 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 15daa0c20048..e9ebff35c147 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,10 @@
# Contributor: Grey Christoforo <first name at last name dot net>
_cranname=pillar
-_cranver=1.8.1
+_cranver=1.9.0
pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
-pkgrel=2
+pkgrel=1
pkgdesc="Coloured Formatting for Columns"
arch=(any)
url="https://cran.r-project.org/package=${_cranname}"
@@ -19,10 +19,11 @@ depends=(
"r-lifecycle"
"r-rlang>=1.0.2"
"r-utf8>=1.1.0"
- "r-vctrs>=0.3.8"
+ "r-vctrs>=0.5.0"
)
optdepends=(
"r-bit64"
+ "r-dbi"
"r-debugme"
"r-diagrammer"
"r-dplyr"
@@ -42,28 +43,42 @@ optdepends=(
"r-vdiffr"
"r-withr"
)
-checkdepends=(
- "${optdepends[@]}"
- "r-testthat>=3.1.1"
-)
+
+# The unittests for `r-pillar` have multiple circular
+# dependency chains.
+
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
+
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-pillar`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat>=3.1.1"
+# )
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-b2sums=('d68f2d37424c729e1c3491183f11ba4ea701f696d7c35c2882507a845e6c4a0b0b2581ae7b626f68a4d716f983088329a24fc2e1f8c6238779a256d875ef9479')
+b2sums=("c626c2618d5461053f3b66b7f230e0202c9b3f63b97da70f3c4d3c650347eef0a780111cc2f9bd97e48eaf641e155c80b9a601bf4b0ed6caaabc9e42233f5fd7")
build() {
mkdir -p "${srcdir}/build/"
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-check() {
- cd "${srcdir}/${_cranname}/tests"
- R_LIBS="${srcdir}/build/" Rscript --vanilla testthat.R
-}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
-
if [[ -f "${_cranname}/LICENSE" ]]; then
install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
fi