summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-02-23 00:01:43 +0000
committerBioArchLinuxBot2024-02-23 00:01:43 +0000
commitab80c8aea773aa9380d5d3fa221003927c20601d (patch)
treeaecd5692035d033b669abbc3b5246ee570bbad9d /PKGBUILD
parentff0deb9fac65bf25a77d961dac98b46267bb1e3c (diff)
downloadaur-ab80c8aea773aa9380d5d3fa221003927c20601d.tar.gz
[lilac] updated to 1.6.4-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index adaa0ce02e4e..3e5d3d789b19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,25 @@
_pkgname=protoclust
_pkgver=1.6.4
pkgname=r-${_pkgname,,}
-pkgver=${_pkgver//[:-]/.}
-pkgrel=1
-pkgdesc='Hierarchical Clustering with Prototypes'
-arch=('x86_64')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="Hierarchical Clustering with Prototypes"
+arch=(x86_64)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-2.0-only')
depends=(
r
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('a')
+md5sums=('06f3a4d3a917a49789c13bdc57424634')
+b2sums=('d62d939b980a74beb8f526802c30d094d20d420d67e24dd061f13c0da0455aee4935f4d84392ac6c93a72386ec9893db4924478d578e88aafcb8f1d3a9a914ba')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: