summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Branham2018-08-16 07:47:57 -0500
committerAlex Branham2018-08-16 07:47:57 -0500
commitaf8881b4a1f8300ee2f0e7e976843cdfd20dc066 (patch)
tree9dcf168259f8afd76b3c94806cd9a0b9a51d4f31 /PKGBUILD
downloadaur-af8881b4a1f8300ee2f0e7e976843cdfd20dc066.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d3044ad2c33
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Alex Branham <branham@utexas.edu>
+_cranver=1.1.0
+pkgname=r-ps
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc='List, Query, Manipulate System Processes'
+arch=('x86_64')
+url='https://cran.r-project.org/package=ps'
+license=('BSD')
+depends=('r' )
+optdepends=('r-callr' 'r-covr' 'r-processx' 'r-r6' 'r-rlang' 'r-testthat' 'r-tibble')
+source=("https://cran.r-project.org/src/contrib/ps_"$_cranver".tar.gz")
+md5sums=('50ca1f0d770f10e76d7a406cdaa95b79')
+
+build(){
+ R CMD INSTALL ps_"$_cranver".tar.gz -l "$srcdir"
+}
+package() {
+ install -dm0755 "$pkgdir"/usr/lib/R/library
+ cp -a --no-preserve=ownership ps "$pkgdir"/usr/lib/R/library
+}
+