summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-06-17 18:05:24 +0000
committerBioArchLinuxBot2023-06-17 18:05:24 +0000
commit20c212ca30174b2f5466eea6f3bc9a76ebd72865 (patch)
tree34d1abf113f121b320e3e9906ebba8423d1e2ff2 /PKGBUILD
parent250ab2d3f2f92ee0c74075430cc67d0c8867a738 (diff)
downloadaur-20c212ca30174b2f5466eea6f3bc9a76ebd72865.tar.gz
[lilac] updated to 0.3.3-12
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 30 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b22c56923777..84bb6f635e40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,52 @@
# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
-_cranname=rappdirs
-_cranver=0.3.3
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=2
+_pkgname=rappdirs
+_pkgver=0.3.3
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//[:-]/.}
+pkgrel=12
pkgdesc="Application Directories: Determine Where to Save Data, Caches, and Logs"
-arch=(i686 x86_64)
-url="https://cran.r-project.org/package=${_cranname}"
+arch=(x86_64)
+url="https://cran.r-project.org/package=${_pkgname}"
license=(MIT)
-depends=(r)
-checkdepends=(r-testthat r-withr)
+depends=(
+ r
+)
+checkdepends=(
+ r-testthat
+ r-withr
+)
optdepends=(
- r-roxygen2
- r-testthat
- r-covr
- r-withr
+ r-covr
+ r-roxygen2
+ r-testthat
+ r-withr
)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz"
- "R-MIT-TEMPLATE::https://cran.r-project.org/web/licenses/MIT")
-sha256sums=('49959f65b45b0b189a2792d6c1339bef59674ecae92f8c2ed9f26ff9e488c184'
- 'e76e4aad5d3d9d606db6f8c460311b6424ebadfce13f5322e9bae9d49cc6090b')
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('cafdd5478c4a6094a9f3d7335fb4f889')
+sha256sums=('49959f65b45b0b189a2792d6c1339bef59674ecae92f8c2ed9f26ff9e488c184')
prepare() {
# fix test snapshot that is incompatible with r-testthat>=3.0.2
- sed -i '5 d' "${_cranname}/tests/testthat/_snaps/appdir.md"
+ sed -i '5d' "$_pkgname/tests/testthat/_snaps/appdir.md"
}
build() {
mkdir -p build
- R CMD INSTALL "${_cranname}" -l "${srcdir}/build"
+ R CMD INSTALL "$_pkgname" -l build
}
check() {
- cd "${_cranname}/tests"
- R_LIBS="${srcdir}/build" NOT_CRAN=true Rscript --vanilla testthat.R
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
-
- cp -a --no-preserve=ownership "build/${_cranname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
- install -Dm644 R-MIT-TEMPLATE "${pkgdir}/usr/share/licenses/${pkgname}/MIT"
- install -Dm644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
}