summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPekka Ristola2022-01-07 14:00:56 +0200
committerPekka Ristola2022-01-07 14:00:56 +0200
commit250ab2d3f2f92ee0c74075430cc67d0c8867a738 (patch)
tree6924e2e115837f995d30fb57e6bd99a30482643f /PKGBUILD
parente8b6ac5041baa9ed8984282eb103205bfa291b1a (diff)
downloadaur-250ab2d3f2f92ee0c74075430cc67d0c8867a738.tar.gz
Add check() function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 31 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b01b439aea9a..b22c56923777 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,48 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
_cranname=rappdirs
_cranver=0.3.3
pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
-pkgrel=1
+pkgrel=2
pkgdesc="Application Directories: Determine Where to Save Data, Caches, and Logs"
arch=(i686 x86_64)
url="https://cran.r-project.org/package=${_cranname}"
license=(MIT)
-depends=('r>=3.2')
-optdepends=(r-roxygen2 r-testthat r-covr r-withr)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=('49959f65b45b0b189a2792d6c1339bef59674ecae92f8c2ed9f26ff9e488c184')
+depends=(r)
+checkdepends=(r-testthat r-withr)
+optdepends=(
+ r-roxygen2
+ r-testthat
+ r-covr
+ r-withr
+)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz"
+ "R-MIT-TEMPLATE::https://cran.r-project.org/web/licenses/MIT")
+sha256sums=('49959f65b45b0b189a2792d6c1339bef59674ecae92f8c2ed9f26ff9e488c184'
+ 'e76e4aad5d3d9d606db6f8c460311b6424ebadfce13f5322e9bae9d49cc6090b')
+
+prepare() {
+ # fix test snapshot that is incompatible with r-testthat>=3.0.2
+ sed -i '5 d' "${_cranname}/tests/testthat/_snaps/appdir.md"
+}
build() {
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "${_cranname}" -l "${srcdir}/build"
+}
+
+check() {
+ cd "${_cranname}/tests"
+ R_LIBS="${srcdir}/build" NOT_CRAN=true Rscript --vanilla testthat.R
}
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/${_cranname}" "${pkgdir}/usr/lib/R/library"
+
+ install -Dm644 R-MIT-TEMPLATE "${pkgdir}/usr/share/licenses/${pkgname}/MIT"
+ install -Dm644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}