summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 19:49:28 +0800
committerSukanka2022-06-06 19:49:28 +0800
commit59c9f2312aa661067926b636b6827d85550ad427 (patch)
tree0d65f57a380ac65952f74ca09d35e5a86bb69328 /PKGBUILD
downloadaur-59c9f2312aa661067926b636b6827d85550ad427.tar.gz
add r-rapportools
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31a391670b01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=rapportools
+_pkgver=1.1
+pkgname=r-${_pkgname,,}
+pkgver=1.1
+pkgrel=3
+pkgdesc='Miscellaneous (stats) helper functions with sane defaults for reporting'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('AGPL')
+depends=(
+ r
+ r-pander
+ r-plyr
+ r-reshape
+ r-reshape2
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('b5fab34bed484d20bb6cf27028f3d9009c482b079298d31a344f84675b342863')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: