summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJooa2018-06-10 12:32:23 +0200
committerJooa2018-06-10 12:32:23 +0200
commit599d3de70dd50aba32b9d42b5ecb0aabbc707eea (patch)
treee8617ee9649db854b3d9f8462711019d158bc9b5 /PKGBUILD
downloadaur-599d3de70dd50aba32b9d42b5ecb0aabbc707eea.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50e1d66e6497
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jooa <aur at (name) dot xyz>
+pkgname=r-raster
+pkgver=2.6
+pkgrel=1
+_cranname=raster
+_cranrel=7
+_pkgfile=${_cranname}_${pkgver}-${_cranrel}.tar.gz
+pkgdesc="Reading, writing, manipulating, analyzing and modeling of gridded spatial data."
+url="https://cran.r-project.org/package=${_cranname}"
+arch=('x86_64' 'i686')
+license=('GPL3')
+depends=('r>=3.0' 'r-sp>=1.2-0')
+provides=('r-raster')
+source=(https://cran.r-project.org/src/contrib/${_pkgfile})
+sha256sums=('fb91804fd465a4a6d9d9858e29fd05f41a99b8efdcc5cf4370ea253b68e42b01')
+
+build() {
+ R CMD INSTALL ${_pkgfile} -l ${srcdir}
+}
+
+package() {
+ install -d ${pkgdir}/usr/lib/R/library
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+}