summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPekka Ristola2023-09-29 14:28:08 +0300
committerPekka Ristola2023-09-29 14:28:08 +0300
commit7918195b41b543d34bc1f59fc62f10700a2c2f2e (patch)
tree8f639d6fa6da09bf95a2556cca4881189e7f7d48 /PKGBUILD
downloadaur-7918195b41b543d34bc1f59fc62f10700a2c2f2e.tar.gz
Version 0.0.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6273b726e932
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=RcppInt64
+_pkgver=0.0.3
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="'Rcpp'-Based Helper Functions to Pass 'Int64' and 'nanotime' Values Between 'R' and 'C++'"
+arch=(x86_64)
+url="https://cran.r-project.org/package=${_pkgname}"
+license=(GPL)
+depends=(
+ r-rcpp
+)
+checkdepends=(
+ r-bit64
+ r-nanotime
+ r-tinytest
+)
+optdepends=(
+ r-bit64
+ r-nanotime
+ r-tinytest
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('722715d7e9579f59b2d7ca4459f220b7')
+sha256sums=('69bd4001de658e4edf8c1a297b7e9be5541778cd7e4b46c80b8929259fb62e37')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" Rscript --vanilla tinytest.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}