summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 20:11:18 +0800
committerSukanka2022-06-06 20:11:18 +0800
commit807e62684c4f84e3925e3e22b0511d06426a2ade (patch)
tree505ef7469d58a85832d1bd2d11f15b117e87fa32 /PKGBUILD
downloadaur-807e62684c4f84e3925e3e22b0511d06426a2ade.tar.gz
add r-reactable
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..680dbb165af5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=reactable
+_pkgver=0.3.0
+pkgname=r-${_pkgname,,}
+pkgver=0.3.0
+pkgrel=3
+pkgdesc="Interactive Data Tables Based on 'React Table'"
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('MIT')
+depends=(
+ r
+ r-digest
+ r-htmltools
+ r-htmlwidgets
+ r-jsonlite
+ r-reactr
+)
+optdepends=(
+ r-covr
+ r-crosstalk
+ r-dplyr
+ r-leaflet
+ r-mass
+ r-rmarkdown
+ r-shiny
+ r-sparkline
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('38e4d49a235f6900e6d7dcb33245c925860edf0b3eb443c78ee0330b6a0c304d')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: