summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 20:36:31 +0800
committerSukanka2022-06-06 20:36:31 +0800
commit8d6063d3c6d0227299b385da3448227ac2bf5d98 (patch)
tree5fc23e2f0153c573358938fe9ffa84ab00cf9ac4 /PKGBUILD
downloadaur-8d6063d3c6d0227299b385da3448227ac2bf5d98.tar.gz
add r-rfastp
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..159082de9936
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# system requirements: GNU make
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=Rfastp
+_pkgver=1.6.0
+pkgname=r-${_pkgname,,}
+pkgver=1.6.0
+pkgrel=1
+pkgdesc='An Ultra-Fast and All-in-One Fastq Preprocessor (Quality Control, Adapter, low quality and polyX trimming) and UMI Sequence Parsing).'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-ggplot2
+ r-rcpp
+ r-reshape2
+ r-rhtslib
+ r-rjson
+ r-zlibbioc
+ make
+)
+optdepends=(
+ r-biocstyle
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('9784da7fd4d1bc36d564dec46ab57f75594d54801b8f825252e274517dabff1b')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: