summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2019-02-09 12:38:14 +0000
committerGrey Christoforo2019-02-09 12:38:14 +0000
commitabede14aa3d1fd64983d263b6eb71ac69595d360 (patch)
tree9a3677ff1f4357e7a943ea7fe5d23c2f658662f6 /PKGBUILD
parent05f81f0037fc24e2a7f69ecce2d6b82e20ce3f86 (diff)
downloadaur-abede14aa3d1fd64983d263b6eb71ac69595d360.tar.gz
version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 12 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 00a5786c4a01..dbad8ab2fbe7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,19 @@
-# Maintainer: Alex Branham <branham@utexas.edu>
-_cranver=0.2.2
+# Contributor: Grey Christoforo <first name at last name dot net>
pkgname=r-rlang
-pkgver=${_cranver//[:-]/.}
+_cran_name=rlang
+pkgver=0.3.1
pkgrel=1
-pkgdesc='Functions for Base Types and Core R and Tidyverse Features'
+pkgdesc="Functions for Base Types and Core R and 'Tidyverse' Features"
arch=('x86_64')
-url='https://cran.r-project.org/package=rlang'
+url="http://cran.r-project.org/web/packages/${_cran_name}/index.html"
license=('GPL3')
-depends=('r' )
-optdepends=('r-crayon' 'r-knitr' 'r-pillar' 'r-rmarkdown' 'r-testthat' 'r-covr')
-replaces=('r-cran-rlang')
-source=("https://cran.r-project.org/src/contrib/rlang_"$_cranver".tar.gz")
-md5sums=('df2abf3a1936c503ed1edd4350ffb5f0')
+depends=('r')
+source=("http://cran.r-project.org/src/contrib/${_cran_name}_${pkgver}.tar.gz")
+md5sums=('58f35460425d475e6a2db267b5039f8f')
-build(){
- R CMD INSTALL rlang_"$_cranver".tar.gz -l "$srcdir"
-}
package() {
- install -dm0755 "$pkgdir"/usr/lib/R/library
- cp -a --no-preserve=ownership rlang "$pkgdir"/usr/lib/R/library
-}
+ mkdir -p $pkgdir/usr/lib/R/library
+ cd $srcdir
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_cran_name}
+}