summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Fink2022-04-03 15:20:59 +0300
committerChristoph Fink2022-04-03 15:20:59 +0300
commit046f0458f93596c6c888aded6026488e67b7a2a6 (patch)
treee307c45c8de06f83795dad9e60207b8d4c35a171 /PKGBUILD
parent4f7a3a8e65dffad354014411872fb3235f6cd8d2 (diff)
downloadaur-046f0458f93596c6c888aded6026488e67b7a2a6.tar.gz
upgpkg: r-rprojroot 2.0.3-1
upstream release upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b155253df2bd..b1cd4b9c1b28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
+# Maintainer: peippo <christoph+aur@christophfink.com>
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
_cranname=rprojroot
-_cranver=2.0.2
+_cranver=2.0.3
pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
@@ -10,9 +11,9 @@ arch=(any)
url="https://cran.r-project.org/package=${_cranname}"
license=(MIT)
depends=('r>=3.0.0')
-optdepends=(r-covr r-knitr r-lifecycle r-mockr r-rmarkdown r-testthat r-withr)
+optdepends=(r-covr r-knitr r-lifecycle r-mockr r-rmarkdown "r-testthat>=3.0.0" r-withr)
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=('5fa161f0d4ac3b7a99dc6aa2d832251001dc92e93c828593a51fe90afd019e1f')
+sha256sums=("50604247470e910cecfe9b76df754bf96a0d701f81b732f7aa9c90a20d30f897")
build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
@@ -20,6 +21,10 @@ build() {
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
-
cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+
+ if [[ -f "${_cranname}/LICENSE" ]]; then
+ install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ fi
+
}