summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Branham2018-10-03 16:43:05 -0500
committerAlex Branham2018-10-03 16:43:05 -0500
commitba29e0abc7796c688d09b54cea5dbb9dc4e878bf (patch)
tree2546809ae3db5789d100b4e6057943e25ff59b54 /PKGBUILD
parentc91b9588396302e42ae425255ab3088b851b20cf (diff)
downloadaur-ba29e0abc7796c688d09b54cea5dbb9dc4e878bf.tar.gz
Upkg 0.8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f4649d875a2..224c6903be35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,22 @@
-# Maintainer: Alex Branham <branham@utexas.edu>
-_cranname=rstudioapi
-_cranver=0.7
-_pkgtar=${_cranname}_${_cranver}.tar.gz
+# Maintainer: Alex Branham <alex.branham@gmail.com>
+_cranver=0.8
pkgname=r-rstudioapi
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc="Safely Access the RStudio API"
+pkgdesc='Safely Access the RStudio API'
arch=('any')
-url="https://cran.r-project.org/package=${_cranname}"
+url='https://cran.r-project.org/package=rstudioapi'
license=('MIT')
depends=('r' )
-
optdepends=('r-testthat' 'r-knitr' 'r-rmarkdown')
-
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
-md5sums=('ee4ab567a7a9fdfac1a6fd01fe38de4a')
+source=("https://cran.r-project.org/src/contrib/rstudioapi_"$_cranver".tar.gz")
+md5sums=('7601abbffcade9bdba3aa982c2c2625a')
build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
+ R CMD INSTALL rstudioapi_"$_cranver".tar.gz -l "$srcdir"
}
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+ install -dm0755 "$pkgdir"/usr/lib/R/library
+ cp -a --no-preserve=ownership rstudioapi "$pkgdir"/usr/lib/R/library
}