summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 21:39:12 +0800
committerSukanka2022-06-06 21:39:12 +0800
commit5025bd433d5375cf12a00cadaeaa4835fc7b456e (patch)
tree15c3a7570b511b81c47dd6c0658f37b85aaf3cac /PKGBUILD
downloadaur-5025bd433d5375cf12a00cadaeaa4835fc7b456e.tar.gz
add r-rsubread
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b48fa138540
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=Rsubread
+_pkgver=2.10.2
+pkgname=r-${_pkgname,,}
+pkgver=2.10.2
+pkgrel=1
+pkgdesc='Mapping, quantification and variant analysis of sequencing data'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('60836921adb5bf8eff956a60f99ac434a70b81e136f7074d401a84dd2dea7edf')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: