summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Fink2023-03-21 18:27:25 +0200
committerChristoph Fink2023-03-21 18:27:25 +0200
commitd3f91acbf4fe724c3f4425883f87ea88c0900ad9 (patch)
tree3fe2a6f43dfa41dcc07fd3d09304bbbd7701c896 /PKGBUILD
parentef087126833d78e3083c203b0247e0c242fae0a8 (diff)
downloadaur-d3f91acbf4fe724c3f4425883f87ea88c0900ad9.tar.gz
upgpkg: r-s4vectors 0.36.2-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e797b4419567..b2d3b2dc9693 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,31 +3,32 @@
# Contributor: Grey Christoforo <first name at last name dot net>
_bcname=S4Vectors
-_bcver=0.34.0
+_bcver=0.36.2
pkgname=r-${_bcname,,}
pkgver=${_bcver//[:-]/.}
pkgrel=1
pkgdesc="Foundation of vector-like and list-like containers in Bioconductor"
arch=(i686 x86_64)
url="https://bioconductor.org/packages/${_bcname}"
-license=(Artistic-2.0)
+license=(Artistic2.0)
depends=(
"r>=4.0.0"
- "r-biocgenerics>=0.37.0"
+ "r-biocgenerics>=0.37.0"
)
optdepends=(
- r-biocstyle
- r-data.table
- r-delayedarray
- r-genomicranges
- r-graph
- r-iranges
- r-runit
- r-shortread
- r-summarizedexperiment
+ "r-biocstyle"
+ "r-data.table"
+ "r-delayedarray"
+ "r-genomicranges"
+ "r-graph"
+ "r-iranges"
+ "r-matrix"
+ "r-runit"
+ "r-shortread"
+ "r-summarizedexperiment"
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_bcname}_${_bcver}.tar.gz")
-sha256sums=("9368ef6636862f02a7cca0022b94975a21a1a4ac434f7b44411c52d83e5c7e48")
+b2sums=('31d38a7dbf8fffb25b5197a52b2d29d673edbc5a3cd347ebf1fb614f1f39bf7af1228516cb5e0494679ed28c3b9448c1f9b4a4b14fba41ed499a0dbe89e98e08')
build() {
R CMD INSTALL ${_bcname}_${_bcver}.tar.gz -l "${srcdir}"