summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Fink2022-04-29 15:03:29 +0300
committerChristoph Fink2022-04-29 15:03:29 +0300
commitef087126833d78e3083c203b0247e0c242fae0a8 (patch)
treed313801d290939d8b5916b4dae220d72fbdce04d /PKGBUILD
parent1f8c7d16576881eb5f13f2d1198f6bc0afd145e8 (diff)
downloadaur-ef087126833d78e3083c203b0247e0c242fae0a8.tar.gz
upgpkg: r-s4vectors 0.34.0-1
upstream release upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 18 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bfee8770fc92..e797b4419567 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
+# Maintainer: peippo <christoph+aur@christophfink.com>
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Grey Christoforo <first name at last name dot net>
_bcname=S4Vectors
-_bcver=0.32.3
+_bcver=0.34.0
pkgname=r-${_bcname,,}
pkgver=${_bcver//[:-]/.}
pkgrel=1
@@ -10,10 +11,23 @@ pkgdesc="Foundation of vector-like and list-like containers in Bioconductor"
arch=(i686 x86_64)
url="https://bioconductor.org/packages/${_bcname}"
license=(Artistic-2.0)
-depends=('r>=4.0.0' 'r-biocgenerics>=0.37.0')
-optdepends=(r-iranges r-genomicranges r-summarizedexperiment r-delayedarray r-shortread r-data.table r-runit r-biocstyle)
+depends=(
+ "r>=4.0.0"
+ "r-biocgenerics>=0.37.0"
+)
+optdepends=(
+ r-biocstyle
+ r-data.table
+ r-delayedarray
+ r-genomicranges
+ r-graph
+ r-iranges
+ r-runit
+ r-shortread
+ r-summarizedexperiment
+)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_bcname}_${_bcver}.tar.gz")
-sha256sums=('9c59328e6a5da87171fb52311f680ac2606d8771807381e1348e2517c84ee272')
+sha256sums=("9368ef6636862f02a7cca0022b94975a21a1a4ac434f7b44411c52d83e5c7e48")
build() {
R CMD INSTALL ${_bcname}_${_bcver}.tar.gz -l "${srcdir}"