summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSaulius Lukauskas2017-03-16 17:12:55 +0000
committerSaulius Lukauskas2017-03-16 17:12:55 +0000
commitfc5bc48f3e94d6c514447272d9e48a8889b89b19 (patch)
treedc7a58938033db84d469aa24c561f95433eb5a4b /PKGBUILD
downloadaur-fc5bc48f3e94d6c514447272d9e48a8889b89b19.tar.gz
init for r-s4vectors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1ea470b639b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Contributor: Sauliusl <luksaulius at gmail>
+pkgname=r-s4vectors
+pkgver=0.12.1
+pkgrel=1
+pkgdesc="S4 implementation of vectors and lists"
+arch=('i686' 'x86_64')
+url="https://bioconductor.org/packages/release/bioc/html/S4Vectors.html"
+license=('Artistic-2.0')
+depends=('r' 'r-biocgenerics')
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/S4Vectors_${pkgver}.tar.gz")
+sha1sums=('b5231866a901fb44096439e89ffc90337de4a6cb')
+
+package() {
+ mkdir -p $pkgdir/usr/lib/R/library
+ cd $srcdir
+
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./S4Vectors
+}