diff options
author | BioArchLinuxBot | 2023-06-18 06:02:07 +0000 |
---|---|---|
committer | BioArchLinuxBot | 2023-06-18 06:02:07 +0000 |
commit | 50a4bba139ffa54c52d7701228b999986ac08c23 (patch) | |
tree | e8fc2c216a59a9c587047336ed33ecaee7c5a4c0 /PKGBUILD | |
parent | a7f39e4686a4a934a0d703af14d971db0a81435c (diff) | |
download | aur-50a4bba139ffa54c52d7701228b999986ac08c23.tar.gz |
[lilac] updated to 0.4.6-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 66 |
1 files changed, 36 insertions, 30 deletions
@@ -1,57 +1,63 @@ # Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com> +# Contributor: Guoyi Zhang <guoyizhang at malacology dot net> # Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com -_cranname=sass -_cranver=0.4.6 -pkgname=r-${_cranname,,} -pkgver=${_cranver//[:-]/.} -pkgrel=1 +_pkgname=sass +_pkgver=0.4.6 +pkgname=r-${_pkgname,,} +pkgver=${_pkgver//[:-]/.} +pkgrel=2 pkgdesc="Syntactically Awesome Style Sheets ('Sass')" -arch=(i686 x86_64) -url="https://cran.r-project.org/package=${_cranname}" +arch=(x86_64) +url="https://cran.r-project.org/package=${_pkgname}" license=(MIT) depends=( - libsass - r-fs - r-rlang - r-htmltools - r-r6 - r-rappdirs + libsass + r-fs + r-htmltools + r-r6 + r-rappdirs + r-rlang +) +checkdepends=( + r-curl + r-testthat + r-withr ) -checkdepends=(r-curl r-testthat r-withr) optdepends=( - r-testthat - r-knitr - r-rmarkdown - r-withr - r-shiny - r-curl + r-curl + r-knitr + r-rmarkdown + r-shiny + r-testthat + r-withr ) -source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz") -sha256sums=('2ee82ce709b7fdee78f7e2364d04f369f58fc2cda4bb5a235bd53c49d311c019') +source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz" + "system-libsass.patch") +md5sums=('fb188e1129cca127e7790ffccff4e1f7' + '6a430d63f1fdeced20c3117763d2cb7c') +sha256sums=('2ee82ce709b7fdee78f7e2364d04f369f58fc2cda4bb5a235bd53c49d311c019' + '5149aa34e5ab5ce03370495705e4162bbf1a3e7c7389be3ebe318c46d394eb10') prepare() { # build against system libsass - sed -e 's|PKG_LIBS = ./libsass/lib/libsass.a|PKG_LIBS = -lsass|' \ - -e '/PKG_CPPFLAGS = -I/d' \ - -e 's|$(SHLIB): libsass/lib/libsass.a|$(SHLIB):|' \ - -i "$_cranname/src/Makevars" + patch -Np1 -i system-libsass.patch } build() { mkdir -p build - R CMD INSTALL "$_cranname" -l build + R CMD INSTALL "$_pkgname" -l build } check() { - cd "$_cranname/tests" + cd "$_pkgname/tests" R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R } package() { install -d "$pkgdir/usr/lib/R/library" - cp -a --no-preserve=ownership "build/$_cranname" "$pkgdir/usr/lib/R/library" + cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library" install -d "$pkgdir/usr/share/licenses/$pkgname" - ln -s "/usr/lib/R/library/$_cranname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname" + ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname" } |