summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Fink2023-03-26 20:28:27 +0300
committerChristoph Fink2023-03-26 20:28:27 +0300
commit80b3c8176adeb107f74e7ef9f7e24870954bd8ad (patch)
tree2bf3b9102ba6a9ee9c501b1da7b44277c8380d92 /PKGBUILD
parent740c01fb85ec435987d32eff6fd9ac86a60a7aa1 (diff)
downloadaur-80b3c8176adeb107f74e7ef9f7e24870954bd8ad.tar.gz
upgpkg: r-scales 1.2.1-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 26 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06866b667b61..f94a64454841 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _cranver=1.2.1
pkgname="r-${_cranname,,}"
pkgdesc="Scale Functions for Visualization"
pkgver="${_cranver//[:-]/.}"
-pkgrel=2
+pkgrel=3
arch=("any")
license=("MIT")
@@ -35,24 +35,41 @@ optdepends=(
"r-stringi"
"r-waldo>=0.4.0"
)
-checkdepends=(
- "${optdepends[@]}"
- "r-testthat>=3.0.0"
-)
+
+# The unittests for `r-scales` have multiple circular
+# dependency chains.
+
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
+
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-scales`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat>=3.0.0"
+# )
+
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
build() {
mkdir -p "${srcdir}/build/"
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-check() {
- R_LIBS="build/" R CMD check --no-manual --as-cran "${_cranname}"
-}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
-
if [[ -f "${_cranname}/LICENSE" ]]; then
install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
fi