summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-02-07 18:02:41 +0000
committerBioArchLinuxBot2024-02-07 18:02:41 +0000
commit37e1768c273f4026130e89a19c99aec6b3a5bc55 (patch)
tree6da4e46d0f96110072c819e70b8d466debaeee87 /PKGBUILD
parent692c17f6b463b9e158da3dabddfbfb32f47eb359 (diff)
downloadaur-37e1768c273f4026130e89a19c99aec6b3a5bc55.tar.gz
[lilac] updated to 1.16.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 33 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e2610b4e242..fe79bce7cb69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
-# system requirements: GNU make
-# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=scGPS
_pkgver=1.16.0
pkgname=r-${_pkgname,,}
-pkgver=1.16.0
-pkgrel=1
-pkgdesc='A complete analysis of single cell subpopulations, from identifying subpopulations to analysing their relationship (scGPS = single cell Global Predictions of Subpopulation)'
-arch=('x86_64')
-url="https://bioconductor.org/packages/${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="A complete analysis of single cell subpopulations, from identifying subpopulations to analysing their relationship (scGPS = single cell Global Predictions of Subpopulation)"
+arch=(x86_64)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('GPL-3.0-only')
depends=(
- r
+ blas
+ lapack
r-caret
r-deseq2
r-dplyr
@@ -25,7 +26,9 @@ depends=(
r-rcppparallel
r-singlecellexperiment
r-summarizedexperiment
- make
+)
+checkdepends=(
+ r-testthat
)
optdepends=(
r-biocparallel
@@ -36,10 +39,8 @@ optdepends=(
r-dose
r-e1071
r-knitr
- r-matrix
r-networkd3
r-org.hs.eg.db
- r-parallel
r-rcolorbrewer
r-reactomepa
r-reshape2
@@ -49,15 +50,29 @@ optdepends=(
r-wgcna
r-xlsx
)
-source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('3a30413a462684cd657530d996dc35dfdb79361d1fc7eb41900e868bfc1ae4f6')
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz"
+ "fix-build.patch")
+md5sums=('5d11fe3a4af0d56d3028d97c6090ccfb'
+ '10f827551e2b78263235e157e5b6a4b2')
+b2sums=('3c265f5702b0701dfc63efef0a5b10f35b326bdc736c03cef0bef699c561fc1956e86cd466dcbb90eaa754d8f8b461f08dc97f429e329d526d568ef8342e4e57'
+ 'e2f840b1d0e9a8897ac8233ce695ea40e658797e01ad46f50bb5e7528efcf3797ec402b22c92d0b8a16c96bd7f4146664b81f9e7998525057426b61d05693e89')
+
+prepare() {
+ # fix linking with onetbb
+ patch -Np1 -i fix-build.patch
+}
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: