summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 22:15:46 +0800
committerSukanka2022-06-06 22:15:46 +0800
commit971e7d8eb0dfedb4708e4934902ece753917c423 (patch)
treea9c47f3182e00a9e6c7580cbf4ff70e40da13942 /PKGBUILD
downloadaur-971e7d8eb0dfedb4708e4934902ece753917c423.tar.gz
add r-scgps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD63
1 files changed, 63 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d657d71f9a49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# system requirements: GNU make
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=scGPS
+_pkgver=1.10.0
+pkgname=r-${_pkgname,,}
+pkgver=1.10.0
+pkgrel=1
+pkgdesc='A complete analysis of single cell subpopulations, from identifying subpopulations to analysing their relationship (scGPS = single cell Global Predictions of Subpopulation)'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-caret
+ r-deseq2
+ r-dplyr
+ r-dynamictreecut
+ r-fastcluster
+ r-ggplot2
+ r-glmnet
+ r-locfit
+ r-rcpp
+ r-rcpparmadillo
+ r-rcppparallel
+ r-singlecellexperiment
+ r-summarizedexperiment
+ make
+)
+optdepends=(
+ r-biocparallel
+ r-clusterprofiler
+ r-cowplot
+ r-dendextend
+ r-devtools
+ r-dose
+ r-e1071
+ r-knitr
+ r-matrix
+ r-networkd3
+ r-org.hs.eg.db
+ r-parallel
+ r-rcolorbrewer
+ r-reactomepa
+ r-reshape2
+ r-rmarkdown
+ r-rtsne
+ r-testthat
+ r-wgcna
+ r-xlsx
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('7f537f1ce15b67dcb9a8eabeb60f36c655158c087d036a8900f4452ffaf1b57c')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: