summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-01-13 18:03:00 +0000
committerBioArchLinuxBot2023-01-13 18:03:00 +0000
commit50480db485a15576db1bccb14ac4c897e69b2972 (patch)
treefef95fa95d54a54b206c90d88a4e0cbbda04438c /PKGBUILD
parent3bcb361e42bbc805a7b3ffd31818b87230f62c82 (diff)
downloadaur-50480db485a15576db1bccb14ac4c897e69b2972.tar.gz
[lilac] updated to 1.20.4-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 35 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 843868ea67c5..5be8fd627e93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,54 +2,82 @@
# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=scPipe
-_pkgver=1.20.2
+_pkgver=1.20.4
pkgname=r-${_pkgname,,}
-pkgver=1.20.2
+pkgver=1.20.4
pkgrel=1
pkgdesc='pipeline for single cell RNA-seq data analysis'
arch=('x86_64')
url="https://bioconductor.org/packages/${_pkgname}"
license=('GPL')
depends=(
+ gcc
+ make
r
r-annotationdbi
+ r-basilisk
r-biocgenerics
r-biomart
+ r-biostrings
+ r-data.table
r-dplyr
+ r-dropletutils
+ r-flexmix
+ r-genomicalignments
r-genomicranges
r-ggally
r-ggplot2
r-glue
r-hash
+ r-iranges
r-magrittr
r-mclust
+ r-multiassayexperiment
r-org.hs.eg.db
r-org.mm.eg.db
+ r-purrr
r-rcpp
r-reshape
+ r-reticulate
r-rhtslib
r-rlang
r-robustbase
+ r-rsamtools
+ r-rsubread
r-rtracklayer
r-s4vectors
r-scales
- r-scater
r-singlecellexperiment
r-stringr
r-summarizedexperiment
r-testthat
+ r-tibble
+ r-tidyr
r-zlibbioc
- gcc
- make
)
optdepends=(
+ r-biocstyle
+ r-dt
+ r-genomicfeatures
+ r-grid
+ r-igraph
+ r-kableextra
r-knitr
+ r-locstra
+ r-plotly
+ r-rann
+ r-rcolorbrewer
+ r-readr
+ r-reshape2
r-rmarkdown
- r-rsubread
+ r-scater
+ r-shiny
r-testthat
+ r-umap
+ r-xml2
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('68a58e3edc68f8d299c816a6764bb2a864a45c072a345fb9bf140c4e1664c0e3')
+sha256sums=('36219e26515a818aaf577207a184b4b826530b0bb8b5ded40bc84d08f751bfb3')
build() {
R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"