summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 22:35:49 +0800
committerSukanka2022-06-06 22:35:49 +0800
commit952cbb9d013010b964de7cc47683433dd37c0ec0 (patch)
tree94ff538b3c3d31b86f3f3da8ba6542ed7fe15d2a /PKGBUILD
downloadaur-952cbb9d013010b964de7cc47683433dd37c0ec0.tar.gz
add r-sepira
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3328cf241f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=SEPIRA
+_pkgver=1.16.0
+pkgname=r-${_pkgname,,}
+pkgver=1.16.0
+pkgrel=1
+pkgdesc='Systems EPigenomics Inference of Regulatory Activity'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-corpcor
+ r-limma
+)
+optdepends=(
+ r-igraph
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('ff360de7089e85531151ee992134e4f8c9bb148eec5da19f982abdbf3768e737')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: