summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 22:51:01 +0800
committerSukanka2022-06-06 22:51:01 +0800
commit85cbb662425b52d244357fddbda047607b030b23 (patch)
tree48ac4efe2af49961a0901c8075a7f389b5ebc20d /PKGBUILD
downloadaur-85cbb662425b52d244357fddbda047607b030b23.tar.gz
add r-shades
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ff95ba4b2f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=shades
+_pkgver=1.4.0
+pkgname=r-${_pkgname,,}
+pkgver=1.4.0
+pkgrel=4
+pkgdesc='Simple Colour Manipulation'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('BSD')
+depends=(
+ r
+)
+optdepends=(
+ r-colorspace
+ r-covr
+ r-ggplot2
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('122fa09aa893cf81f95835ccf69459162dbbc14defa0c11c6d6bbb0ca52ee9fd')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENCE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: