summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsukanka2022-11-13 20:18:18 +0800
committersukanka2022-11-13 20:18:18 +0800
commit715fc6c8c1cd0351fea001ab5358d17bdc25b504 (patch)
tree707be6b9480781784578c0cb5723bd492cbcbfb0 /PKGBUILD
downloadaur-715fc6c8c1cd0351fea001ab5358d17bdc25b504.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d81829ac79a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: sukanka <su975853527@gmail.com>
+
+_pkgname=shinyvalidate
+_pkgver=0.1.2
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//[:-]/.}
+pkgrel=1
+pkgdesc='Input Validation for Shiny Apps'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('MIT')
+depends=(
+ r
+ r-glue
+ r-htmltools
+ r-rlang
+ r-shiny
+)
+optdepends=(
+ r-covr
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('4751015af9fe37b03885cdf261bafff72deea425bd331a82ebaba9998332fa56')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: