summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 23:23:43 +0800
committerSukanka2022-06-06 23:23:43 +0800
commit7b9a45005e3b79a25e7e7f143f8baeb1f0163b55 (patch)
treee311886435290f85377554164f2ebf9a29504384 /PKGBUILD
downloadaur-7b9a45005e3b79a25e7e7f143f8baeb1f0163b55.tar.gz
add r-sm
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b7a646566d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=sm
+_pkgver=2.2-5.7
+pkgname=r-${_pkgname,,}
+pkgver=2.2.5.7
+pkgrel=4
+pkgdesc='Smoothing Methods for Nonparametric Regression and Density Estimation'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+)
+optdepends=(
+ r-akima
+ r-gam
+ r-misc3d
+ r-rgl
+ r-rpanel
+ r-tcltk
+ r-tkrplot
+)
+makedepends=(
+ gcc-fortran
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('2607a2cafc68d7e99005daf99e36f4a66eaf569ebb6b7500e962642cf58be80f')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: