summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-07 00:30:47 +0800
committerSukanka2022-06-07 00:30:47 +0800
commit7ed45a5d9e7d10b2732f53b1eb02b80d9b7a9122 (patch)
tree34e95a0de3e7f4c872dc979f66ed58fadd913792 /PKGBUILD
downloadaur-7ed45a5d9e7d10b2732f53b1eb02b80d9b7a9122.tar.gz
add r-splatter
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD71
1 files changed, 71 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27a0f3a733a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=splatter
+_pkgver=1.20.0
+pkgname=r-${_pkgname,,}
+pkgver=1.20.0
+pkgrel=1
+pkgdesc='Simple Simulation of Single-cell RNA Sequencing Data'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-biocgenerics
+ r-biocparallel
+ r-checkmate
+ r-crayon
+ r-edger
+ r-fitdistrplus
+ r-ggplot2
+ r-locfit
+ r-matrixstats
+ r-s4vectors
+ r-scales
+ r-scater
+ r-singlecellexperiment
+ r-summarizedexperiment
+)
+optdepends=(
+ r-basics
+ r-biocmanager
+ r-biocsingular
+ r-biocstyle
+ r-biostrings
+ r-covr
+ r-cowplot
+ r-genomeinfodb
+ r-genomicranges
+ r-igraph
+ r-iranges
+ r-knitr
+ r-limsolve
+ r-lme4
+ r-magick
+ r-mfa
+ r-phenopath
+ r-preprocesscore
+ r-progress
+ r-pscl
+ r-rmarkdown
+ r-scdd
+ r-scran
+ r-scuttle
+ r-sparsedc
+ r-spelling
+ r-testthat
+ r-variantannotation
+ r-zinbwave
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('0eaf0ef914c0a8fdffe6ddaff6dc98441a4a9016fb26972cd03faaae65e005ae')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: