summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-07 01:09:19 +0800
committerSukanka2022-06-07 01:09:19 +0800
commit5e30bb51124b93ab0875e92fde591465fea58bd6 (patch)
tree33e7fb7417b4a605c3ca75513731077e37e5567a /PKGBUILD
downloadaur-5e30bb51124b93ab0875e92fde591465fea58bd6.tar.gz
add r-swathxtend
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..427da0d3879c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=SwathXtend
+_pkgver=2.18.0
+pkgname=r-${_pkgname,,}
+pkgver=2.18.0
+pkgrel=1
+pkgdesc='SWATH extended library generation and statistical data analysis'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-e1071
+ r-openxlsx
+ r-venndiagram
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('e4fe1af7d1d3a75494066dcf203af22ec46f52958e4470b7d0f7ef0b8080930a')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: