summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsukanka2023-01-27 10:57:58 +0800
committersukanka2023-01-27 10:57:58 +0800
commited2b8ea93e04e2dc84afc6a19cd2bb9febcbe9fb (patch)
tree9bde5fb106afbb24838da653002b5e7913674166 /PKGBUILD
downloadaur-ed2b8ea93e04e2dc84afc6a19cd2bb9febcbe9fb.tar.gz
add package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2fbee64fd6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sukanka <su975853527@gmail.com>
+
+_pkgname=symmoments
+_pkgver=1.2.1
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//[:-]/.}
+pkgrel=1
+pkgdesc='Symbolic Central and Noncentral Moments of the Multivariate Normal Distribution'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-combinat
+ r-cubature
+ r-multipol
+ r-mvtnorm
+)
+optdepends=(
+ r-ape
+ r-mpoly
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('9a6be1f8fe44f6ab5a1790e870fd8b18de1686a48a14a9fca2d035bfb5458672')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: