summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-07 01:24:49 +0800
committerSukanka2022-06-07 01:24:49 +0800
commitb2debec40fabc966f0467d1b3803e52d7a861ba4 (patch)
treeeb3427d10a82ba1cb9389eababaaf20e60fead88 /PKGBUILD
downloadaur-b2debec40fabc966f0467d1b3803e52d7a861ba4.tar.gz
add r-teachingdemos
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f78295811254
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=TeachingDemos
+_pkgver=2.12
+pkgname=r-${_pkgname,,}
+pkgver=2.12
+pkgrel=4
+pkgdesc='Demonstrations for Teaching and Learning'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+)
+optdepends=(
+ r-ggplot2
+ r-lattice
+ r-logspline
+ r-manipulate
+ r-maptools
+ r-mass
+ r-png
+ r-r2wd
+ r-rgl
+ r-tcltk
+ r-tcltk2
+ r-tkrplot
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('3e75405ce1affa406d6df85e06f96381412bc7a2810b25d8c81bfe64c4698644')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: