summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-07 01:27:52 +0800
committerSukanka2022-06-07 01:27:52 +0800
commit04e4f9973597523f45710d36d40fb201550af456 (patch)
treec4d1aa37bb4272f714ba68877a14f64d844264b4 /PKGBUILD
downloadaur-04e4f9973597523f45710d36d40fb201550af456.tar.gz
add r-tester
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd6181226c35
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=tester
+_pkgver=0.1.7
+pkgname=r-${_pkgname,,}
+pkgver=0.1.7
+pkgrel=4
+pkgdesc='Tests and checks characteristics of R objects'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+)
+optdepends=(
+ r-knitr
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('b9c645119c21c69450f3d366c911ed92ac7c14ef61652fd676a38fb9d420b5f4')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: