summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-07 01:48:46 +0800
committerSukanka2022-06-07 01:48:46 +0800
commitb0864fc21bef1490119b3d1d15141f7133b97192 (patch)
tree7b7138550fa6b98b0a6bfd710d6fc4ae8ff73da5 /PKGBUILD
downloadaur-b0864fc21bef1490119b3d1d15141f7133b97192.tar.gz
add r-topconfects
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82cc4569f6db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=topconfects
+_pkgver=1.12.0
+pkgname=r-${_pkgname,,}
+pkgver=1.12.0
+pkgrel=1
+pkgdesc='Top Confident Effect Sizes'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('LGPL')
+depends=(
+ r
+ r-assertthat
+ r-ggplot2
+)
+optdepends=(
+ r-annotationdbi
+ r-ashr
+ r-biocstyle
+ r-deseq2
+ r-dplyr
+ r-edger
+ r-knitr
+ r-limma
+ r-nbpseq
+ r-org.at.tair.db
+ r-readr
+ r-reshape2
+ r-rmarkdown
+ r-statmod
+ r-testthat
+ r-tidyr
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('93bca22f8636f1b3e7259ac63cfa5e019e893de279175f3febb8f1b5dfc12c6c')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: