summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsukanka2022-07-21 23:09:18 +0800
committersukanka2022-07-21 23:09:18 +0800
commit184c6e3107deaa25655eb2461e97babc9f72cb06 (patch)
tree593f221833d1fc689b70927f919a499d72fc7cf0 /PKGBUILD
parent3df1a49a56f1292cd7c146e747a1a0f053197a84 (diff)
downloadaur-184c6e3107deaa25655eb2461e97babc9f72cb06.tar.gz
takeover package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 31 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b4d92f764ddb..a21a2f3448c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,38 @@
-# Maintainer: Robert Greener <me@r0bert.dev>
-# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
-
-_cranname=V8
-_cranver=4.2.0
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
-pkgdesc="Embedded JavaScript and WebAssembly Engine for R"
-arch=(i686 x86_64)
-url="https://cran.r-project.org/package=${_cranname}"
-license=(MIT)
-depends=(r 'r-rcpp>=0.12.12' 'r-jsonlite>=1.0' 'r-curl>=1.0' v8)
-optdepends=(r-testthat r-knitr r-rmarkdown)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha512sums=("71d74c0cc4c05c4b6914637efd628d56435f59d23b9c02c2bd5195c503cbcc6c2fcc07382b129bec286b37e6b9a3c64d8b81f0bd7e2a24c063576c172229d7cb")
+# system requirements: V8 engine version 6+ is needed for ES6 and WASMsupport. On Linux you can also build against libv8-dev (Debian)or v8-devel (Fedora). We also provide static libv8 binaries formost platforms, see the README for details.
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+_pkgname=V8
+_pkgver=4.2.0
+pkgname=r-${_pkgname,,}
+pkgver=4.2.0
+pkgrel=3
+pkgdesc='Embedded JavaScript and WebAssembly Engine for R'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('MIT')
+depends=(
+ r
+ r-curl
+ r-jsonlite
+ r-rcpp
+ v8
+ make
+)
+optdepends=(
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('6c62fdc974cc30fa975cad4ccb1e3796112fc2490a807f6e3d7878c3a5544743')
+options=(staticlibs)
build() {
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
}
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
-
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
+# vim:set ts=2 sw=2 et: