summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorViktor Drobot2020-07-09 15:51:53 +0300
committerViktor Drobot2020-07-09 15:51:53 +0300
commit473eec2ecfa33e2d2f4b9a24f9968aa02bab4bf2 (patch)
treed5fa4bba7475a58a775176f4ba4a518d60583a83 /PKGBUILD
downloadaur-473eec2ecfa33e2d2f4b9a24f9968aa02bab4bf2.tar.gz
First release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66649d7f968f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+_cranname=V8
+_cranver=3.2.0
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Embedded JavaScript and WebAssembly Engine for R"
+arch=(i686 x86_64)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(MIT)
+depends=(r 'r-rcpp>=0.12.12' 'r-jsonlite>=1.0' 'r-curl>=1.0' 'v8>=6')
+makedepends=(gcc)
+optdepends=(r-testthat r-knitr r-rmarkdown)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('1a263bcebad340ac716c49d3b11d46d1')
+
+build() {
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+}