summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-01-31 18:01:36 +0000
committerBioArchLinuxBot2024-01-31 18:01:36 +0000
commit6a5a6d1c04b07ee8acada3d2464146063f9c455a (patch)
treecaf248e4032bd3194b29f797b0f4efbfae2885a6 /PKGBUILD
parent51a143fe19e6d24269dd81ab43296b2d783173a3 (diff)
downloadaur-6a5a6d1c04b07ee8acada3d2464146063f9c455a.tar.gz
[lilac] updated to 4.4.1-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ca7d7eeb70e0..f819c8851262 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,16 +7,16 @@ _pkgname=V8
_pkgver=4.4.1
pkgname=r-${_pkgname,,}
pkgver=${_pkgver//-/.}
-pkgrel=1
+pkgrel=2
pkgdesc="Embedded JavaScript and WebAssembly Engine for R"
arch=(x86_64)
-url="https://cran.r-project.org/package=${_pkgname}"
-license=(MIT)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('MIT')
depends=(
- nodejs
r-curl
r-jsonlite
r-rcpp
+ v8-r
)
checkdepends=(
r-testthat
@@ -28,12 +28,11 @@ optdepends=(
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
md5sums=('3060d1c091396baabfe5d52789058e09')
-sha256sums=('5b6dd6133d83f3cc7297d0369706070f26c376d6ce6fb4cfcf2ad5308abd3a89')
+b2sums=('38939d2188bba7d7ae3b536cd88330ffe51d914f2339c0a495bd3f4b34857b333176e5849563e96ad9784892d30a91892416ad066b9e1e2e9dad4a4296dca82f')
build() {
- mkdir -p build
- R CMD INSTALL "$_pkgname" -l build \
- --configure-vars="V8_PKG_LIBS=-lnode V8_PKG_CFLAGS=-I/usr/include/node"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
check() {