summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-07 02:29:42 +0800
committerSukanka2022-06-07 02:29:42 +0800
commit7b96d02db312df5695628ad6b7aa74320f7a2968 (patch)
treeea293b0cbb098a9f249b87a4bf1ac59b50a35610 /PKGBUILD
downloadaur-7b96d02db312df5695628ad6b7aa74320f7a2968.tar.gz
add r-varcon
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa98329ef976
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=VarCon
+_pkgver=1.4.0
+pkgname=r-${_pkgname,,}
+pkgver=1.4.0
+pkgrel=1
+pkgdesc='VarCon: an R package for retrieving neighboring nucleotides of an SNV'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-biostrings
+ r-bsgenome
+ r-genomicranges
+ r-ggplot2
+ r-iranges
+ r-shiny
+ r-shinycssloaders
+ r-shinyfiles
+)
+optdepends=(
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('1f12f73092c432600bfa0e8e568b6470f5f1bee4ff92a0c5ed73fa0a857e1b50')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: