summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-07 02:35:20 +0800
committerSukanka2022-06-07 02:35:20 +0800
commitc07a22e3469bbd4586060e425ec69b11468b4188 (patch)
tree1cb638dc23433b328f432beb1577e1aa0b164ec6 /PKGBUILD
downloadaur-c07a22e3469bbd4586060e425ec69b11468b4188.tar.gz
add r-vcfarray
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8cf2305f76cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=VCFArray
+_pkgver=1.12.0
+pkgname=r-${_pkgname,,}
+pkgver=1.12.0
+pkgrel=1
+pkgdesc='Representing on-disk / remote VCF files as array-like objects'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-biocgenerics
+ r-delayedarray
+ r-genomicfiles
+ r-genomicranges
+ r-rsamtools
+ r-s4vectors
+ r-variantannotation
+)
+optdepends=(
+ r-biocmanager
+ r-biocstyle
+ r-knitr
+ r-rmarkdown
+ r-seqarray
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('490a97af0ee4ee1a4482bf03d322fde6ad7bb1ff09544fbf97220566d1e6ef9f')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: