summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Fink2022-03-30 21:37:06 +0300
committerChristoph Fink2022-03-30 21:37:06 +0300
commit52869474abbddbbf09c2f14dc5247863253a06c7 (patch)
tree140f71761ea15fc63816934103be14ea8deb17ea /PKGBUILD
parente87c1e22edb7842cd0d7612a183d9ea671818b6f (diff)
downloadaur-52869474abbddbbf09c2f14dc5247863253a06c7.tar.gz
upgpkg: r-vctrs 0.4.0-1
upstream release upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 31 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 647cf38fef29..d188f8d7f98c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
+# Maintainer: peippo <christoph+aur@christophfink.com>
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Grey Christoforo <first name at last name dot net>
_cranname=vctrs
-_cranver=0.3.8
+_cranver=0.4.0
pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
@@ -10,10 +11,31 @@ pkgdesc="Vector Helpers"
arch=(i686 x86_64)
url="https://cran.r-project.org/package=${_cranname}"
license=(MIT)
-depends=('r>=3.3' 'r-ellipsis>=0.2.0' r-glue 'r-rlang>=0.4.10')
-optdepends=(r-bit64 r-covr r-crayon r-dplyr r-generics r-knitr r-pillar r-pkgdown r-rmarkdown r-testthat r-tibble r-withr r-xml2 r-waldo r-zeallot)
+depends=(
+ "r>=3.3"
+ "r-cli>=3.2.0"
+ "r-glue"
+ "r-rlang>=1.0.2"
+)
+optdepends=(
+ "r-bit64"
+ "r-covr"
+ "r-crayon"
+ "r-dplyr>=0.8.5"
+ "r-generics"
+ "r-knitr"
+ "r-pillar>=1.4.4"
+ "r-pkgdown>=2.0.1"
+ "r-rmarkdown"
+ "r-testthat>=3.0.0"
+ "r-tibble>=3.1.3"
+ "r-withr"
+ "r-xml2"
+ "r-waldo>=0.2.0"
+ "r-zeallot"
+)
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=('7f4e8b75eda115e69dddf714f0643eb889ad61017cdc13af24389aab2a2d1bb1')
+sha256sums=("89dee789aad9b06b2f314ece8de2d6c261a5cd5729a8a00be99d5b2b85c8542f")
build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
@@ -23,4 +45,9 @@ package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+
+ if [[ -f "${_cranname}/LICENSE" ]]; then
+ install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ fi
+
}