summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-07 02:42:10 +0800
committerSukanka2022-06-07 02:42:10 +0800
commit17549da3c8039e2a50d0b89c7d060ee20059303c (patch)
tree360d38efffa42ba68221933c0f7d25d863eb609f /PKGBUILD
downloadaur-17549da3c8039e2a50d0b89c7d060ee20059303c.tar.gz
add r-viseago
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 60 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0430a0a0e5a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=ViSEAGO
+_pkgver=1.10.0
+pkgname=r-${_pkgname,,}
+pkgver=1.10.0
+pkgrel=1
+pkgdesc='ViSEAGO: a Bioconductor package for clustering biological functions using Gene Ontology and semantic similarity'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-annotationdbi
+ r-annotationforge
+ r-biomart
+ r-data.table
+ r-dendextend
+ r-diagrammer
+ r-dt
+ r-dynamictreecut
+ r-fgsea
+ r-ggplot2
+ r-go.db
+ r-gosemsim
+ r-heatmaply
+ r-htmlwidgets
+ r-igraph
+ r-plotly
+ r-processx
+ r-r.utils
+ r-rcolorbrewer
+ r-scales
+ r-topgo
+ r-upsetr
+)
+optdepends=(
+ r-biocmanager
+ r-biocstyle
+ r-corrplot
+ r-htmltools
+ r-knitr
+ r-limma
+ r-org.mm.eg.db
+ r-remotes
+ r-rgraphviz
+ r-rmarkdown
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('cd2c6399b3cf1d3fc1da6f15c92a49e412c768f0d8dd4c4e5fe9abd35840bd68')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: