summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Fink2023-03-26 20:50:34 +0300
committerChristoph Fink2023-03-26 20:50:34 +0300
commitee3b33da9779cc43ce5b29424508c31bfd6fcba3 (patch)
tree456d1a9883001f3348983a01389a4153b96a122e /PKGBUILD
parent9b58ca3cc42e286dbfc23ba4617583379196ff2b (diff)
downloadaur-ee3b33da9779cc43ce5b29424508c31bfd6fcba3.tar.gz
upgpkg: r-waldo 0.4.0-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 25 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 695441b04a09..a8cfc12a1658 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgdesc="Anything to ‘POSIXct’ or ‘Date’ Converter"
url="https://cran.r-project.org/package=${_cranname}"
license=("MIT")
pkgver=${_cranver//[:-]/.}
-pkgrel=2
+pkgrel=3
arch=("any")
depends=(
@@ -20,7 +20,7 @@ depends=(
"r-glue"
"r-rematch2"
"r-rlang>=1.0.0"
- "r-tibble"
+# "r-tibble"
)
optdepends=(
"r-covr"
@@ -28,10 +28,25 @@ optdepends=(
"r-withr"
"r-xml2"
)
-checkdepends=(
- "${optdepends[@]}"
- "r-testthat"
-)
+
+# The unittests for `r-waldo` have multiple circular
+# dependency chains.
+
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
+
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-waldo`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat"
+# )
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
b2sums=("aaf9e2146afd7b3bc4b21f75a47c85358c02978c4250a33255a501db4b27b4254d060d31651d3dee35ae8e0438810aae8d5e6c5ff1466d5af1d654d751731a2f")
@@ -41,14 +56,14 @@ build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-check() {
- R_LIBS="build/" R CMD check --no-manual --as-cran "${_cranname}"
-}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
-
if [[ -f "${_cranname}/LICENSE" ]]; then
install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
fi