summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Branham2018-05-31 11:02:49 -0500
committerAlex Branham2018-05-31 11:02:49 -0500
commit691c3742b42011c5dfa7af12a76133c175bad099 (patch)
tree0bcc1ba6840d316efa282c0ee8b861e50abee8de /PKGBUILD
parente8cffd140ee51d630feaf277bea804603bee5774 (diff)
downloadaur-691c3742b42011c5dfa7af12a76133c175bad099.tar.gz
Upkg 2.1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 19 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ddf250f2e5de..5611957041eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,26 @@
-# Maintainer: generated by script at https://github.com/zasdfgbnm/aurcran
-
-_pkgname=withr
-_pkgnamelower=withr
-_repo='http://cran.stat.ucla.edu/'
-_cran="https://cran.r-project.org/web/packages/$_pkgname/index.html"
-pkgname=r-$_pkgnamelower
-pkgver=1.0.2
+# Maintainer: Alex Branham <branham@utexas.edu>
+_cranname=withr
+_cranver=2.1.2
+_pkgtar=${_cranname}_${_cranver}.tar.gz
+pkgname=r-withr
+pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc='run code 'with' temporarily modified global state'
-arch=(any)
-url="http://github.com/jimhester/withr"
+pkgdesc="Run Code With Temporarily Modified Global State"
+arch=('any')
+url="https://cran.r-project.org/package=${_cranname}"
license=('GPL')
-depends=('r>=3.0.2')
-makedepends=('curl' 'grep' 'python-html2text')
+depends=('r' )
-pkgver() {
- curl "$_cran" 2>/dev/null|html2text|grep -oP '(?<=Version:).*'|tr '-' '.'|grep -o '[0-9\.]*'
-}
+optdepends=('r-testthat' 'r-covr' 'r-dbi' 'r-knitr' 'r-rmarkdown')
-build() {
- Rscript -e "install.packages(\"$_pkgname\", lib=\"$srcdir\", repos=\"$_repo\")"
-}
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+md5sums=('85e8574fb0a6832c4f275531be6371d6')
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
package() {
install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_pkgname" "$pkgdir/usr/lib/R/library"
-} \ No newline at end of file
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+}
+