summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXiang Gao2016-08-11 12:26:10 -0400
committerXiang Gao2016-08-11 12:26:10 -0400
commitcde71dfcc0948ba0349e8358f23a1a2ae0ca5576 (patch)
tree2f9dab7e0b7d2f6e251ef1d23a62d8f0fe5c6f78 /PKGBUILD
downloadaur-cde71dfcc0948ba0349e8358f23a1a2ae0ca5576.tar.gz
init version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..962543155d73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: generated by script at https://github.com/zasdfgbnm/aurcran
+
+_pkgname=withr
+_pkgnamelower=withr
+_repo='http://cran.stat.ucla.edu/'
+_cran="https://cran.r-project.org/web/packages/$_pkgname/index.html"
+pkgname=r-$_pkgnamelower
+pkgver=1.0.2
+pkgrel=1
+pkgdesc='run code 'with' temporarily modified global state'
+arch=(any)
+url="http://github.com/jimhester/withr"
+license=('GPL')
+depends=('r>=3.0.2')
+makedepends=('curl' 'grep' 'python-html2text')
+
+pkgver() {
+ curl "$_cran" 2>/dev/null|html2text|grep -oP '(?<=Version:).*'|grep -o '[0-9\.]*'
+}
+
+build() {
+ Rscript -e "install.packages(\"$_pkgname\", lib=\"$srcdir\", repos=\"$_repo\")"
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_pkgname" "$pkgdir/usr/lib/R/library"
+} \ No newline at end of file