summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Fink2023-08-25 17:01:31 +0300
committerChristoph Fink2023-08-25 17:02:03 +0300
commit62c561ea751a8a4ebe708d8be1f0a145419c3014 (patch)
treee2cf328a198246b10b29197999f3d470af2a426b /PKGBUILD
parentd7e3e1c6212b2fa83503275ebfe263df006d84a0 (diff)
downloadaur-62c561ea751a8a4ebe708d8be1f0a145419c3014.tar.gz
upgpkg: r-wk 0.8.0-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e4c3a3eef661..aaf536f3c67e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: peippo <christoph+aur@christophfink.com>
_cranname=wk
-_cranver=0.7.3
+_cranver=0.8.0
pkgname=r-${_cranname,,}
pkgdesc="Lightweight Well-Known Geometry Parsing"
url="https://cran.r-project.org/package=${_cranname}"
@@ -35,23 +35,23 @@ optdepends=(
# the build chroot), uncomment the lines defining `checkdepends`, below,
# as well as the `check()` function further down
-# checkdepends=(
-# "${optdepends[@]}"
-# "r-testthat>=3.0.0"
-# )
+checkdepends=(
+ "${optdepends[@]}"
+ "r-testthat>=3.0.0"
+)
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-b2sums=("d8403dcda31a87546a7ae18e5268473af3bfbdbc38eb4100b2fcfd0c2c529d27ccecde9d3d3b6c42850a194768ed832bce271ea1309c4a6263516d3e1273ea0f")
+b2sums=("4c13054ce7e2be903a4c5a877f64426ef183102227432088ddaba09128cec61e38119a6946f5e8e0df6038667f57d9f5a25f0839a0875006c62bafc45bfe2f97")
build() {
mkdir -p "${srcdir}/build/"
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-# check() {
-# export R_LIBS="build/"
-# R CMD check --no-manual "${_cranname}"
-# }
+check() {
+ export R_LIBS="build/"
+ R CMD check --no-manual "${_cranname}"
+}
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"