summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Branham2018-07-09 07:50:30 -0500
committerAlex Branham2018-07-09 07:50:30 -0500
commitb8762e5ff29a67697f1e8c752b9e85223877b6ec (patch)
treee537bbc6636ddc17b6f28c3b1b430380f2f485a3 /PKGBUILD
downloadaur-b8762e5ff29a67697f1e8c752b9e85223877b6ec.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8928af5d67ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Alex Branham <branham@utexas.edu>
+_cranver=0.3
+pkgname=r-xfun
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc='Miscellaneous Functions by Yihui Xie'
+arch=('any')
+url='https://cran.r-project.org/package=xfun'
+license=('MIT')
+depends=('r' )
+optdepends=('r-testit' 'r-rstudioapi' 'r-tinytex' 'r-mime' 'r-markdown' 'r-knitr' 'r-rmarkdown')
+source=("https://cran.r-project.org/src/contrib/xfun_"$_cranver".tar.gz")
+md5sums=('bd8bac6a329a1c99dd1f9ddb7e80917a')
+
+build(){
+ R CMD INSTALL xfun_"$_cranver".tar.gz -l "$srcdir"
+}
+package() {
+ install -d "$pkgdir"/usr/lib/R/library
+ cp -a --no-preserve=ownership xfun "$pkgdir"/usr/lib/R/library
+}
+