summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-07 02:58:49 +0800
committerSukanka2022-06-07 02:58:49 +0800
commit6eb734e29a1ef35c4a9b5a5f019837719ec81241 (patch)
tree032f36f82a16b8bd4dace7a7d77ea831144c02b4 /PKGBUILD
downloadaur-6eb734e29a1ef35c4a9b5a5f019837719ec81241.tar.gz
add r-xmapbridge
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d793b8f60b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=xmapbridge
+_pkgver=1.54.0
+pkgname=r-${_pkgname,,}
+pkgver=1.54.0
+pkgrel=1
+pkgdesc='Export plotting files to the xmapBridge for visualisation in X:Map'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('LGPL')
+depends=(
+ r
+)
+optdepends=(
+ r-rcolorbrewer
+ r-runit
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('20bc67e2aa68957c9882836d746153494c6f45515f8313c5f8c5752e09eb76d8')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: