summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Branham2018-07-16 09:06:11 -0500
committerAlex Branham2018-07-16 09:06:11 -0500
commit2480166226407513d6747108833173fb6577309b (patch)
treeb034713036341b37d95fc0d35a15fd7ef9042e7c /PKGBUILD
parent42cc1a8238bd56fb83982625fefeae284c55902a (diff)
downloadaur-2480166226407513d6747108833173fb6577309b.tar.gz
Upkg 3.98.1.12
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd340b02a454..fdc8cb292cc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,23 @@
# Maintainer: Alex Branham <branham@utexas.edu>
-_cranname=XML
-_cranver=3.98-1.11
-_pkgtar=${_cranname}_${_cranver}.tar.gz
+_cranver=3.98-1.12
pkgname=r-xml
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc="Tools for Parsing and Generating XML Within R and S-Plus"
+pkgdesc='Tools for Parsing and Generating XML Within R and S-Plus'
arch=('x86_64')
-url="https://cran.r-project.org/package=${_cranname}"
+url='https://cran.r-project.org/package=XML'
license=('BSD_2_clause + file LICENSE')
depends=('r' 'libxml2')
-
optdepends=('r-bitops' 'r-rcurl')
-
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
-md5sums=('6c67f5730ada3456372520773a920b8e')
replaces=('r-cran-xml')
+source=("https://cran.r-project.org/src/contrib/XML_"$_cranver".tar.gz")
+md5sums=('a0b043a383b9815d52ebdfaedc08a68e')
build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
+ R CMD INSTALL XML_"$_cranver".tar.gz -l "$srcdir"
}
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+ install -d "$pkgdir"/usr/lib/R/library
+ cp -a --no-preserve=ownership XML "$pkgdir"/usr/lib/R/library
}