summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Branham2018-05-31 17:05:57 -0500
committerAlex Branham2018-05-31 17:05:57 -0500
commit819c0a3d41b41ee821cd7da304c9993546efbe40 (patch)
treee4a174bfca77d91de45d4ac49456d811bedc4705 /PKGBUILD
downloadaur-819c0a3d41b41ee821cd7da304c9993546efbe40.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7aae478833c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alex Branham <branham@utexas.edu>
+_cranname=zip
+_cranver=1.0.0
+_pkgtar=${_cranname}_${_cranver}.tar.gz
+pkgname=r-zip
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Cross-Platform zip Compression"
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_cranname}"
+license=('CC0')
+depends=('r' )
+
+optdepends=('r-covr' 'r-testthat' 'r-withr')
+
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+md5sums=('0e019bf0f5d9a7c182f9aebf51a7e883')
+
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+}
+