diff options
author | bartus | 2021-06-11 13:24:29 +0200 |
---|---|---|
committer | bartus | 2021-06-11 13:24:29 +0200 |
commit | 15d4d9f2e714d85e626d4fe95dd403f8b131d2fc (patch) | |
tree | 607ffb572ce11651d8fd0e56d4aef2929bcd7763 /PKGBUILD | |
parent | 04b51e3f80eb05c95172f962b2e702e30f45ab3a (diff) | |
download | aur-15d4d9f2e714d85e626d4fe95dd403f8b131d2fc.tar.gz |
Rename to r2-iaito-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 36 |
1 files changed, 17 insertions, 19 deletions
@@ -2,29 +2,28 @@ ((DISABLE_BUNDLED_RADARE)) && { depends+=('radare2>=5.1.0') - _CMAKE_FLAGS+=(-DCUTTER_USE_BUNDLED_RADARE2=OFF) + _CMAKE_FLAGS+=(-DIAITO_USE_BUNDLED_RADARE2=OFF) } || { source+=("radare2::git+https://github.com/radareorg/radare2") md5sums+=('SKIP') - _CMAKE_FLAGS+=(-DCUTTER_USE_BUNDLED_RADARE2=ON) + _CMAKE_FLAGS+=(-DIAITO_USE_BUNDLED_RADARE2=ON) } -pkgname=radare2-cutter-git +pkgname=r2-iaito-git epoch=1 -pkgver=0.1.0.r2.gbaf2c363 +pkgver=5.2.2.r2.g54dc54d5 pkgrel=1 -pkgdesc='Qt and C++ GUI for radare2 reverse engineering framework (originally named Iaito)' -url='https://github.com/radareorg/cutter' +pkgdesc='Qt and C++ GUI for radare2 reverse engineering framework (fork of Cutter)' +url='https://github.com/radareorg/iaito' arch=('x86_64') license=('GPL3') depends+=('python' 'capstone' 'qt5-base' 'qt5-svg' 'qt5-webengine' 'icu' 'python-shiboken2' 'pyside2' 'graphviz' 'qt5-tools' 'syntax-highlighting') makedepends=('git' 'cmake' 'shiboken2' 'meson' 'ninja') optdepends=() -provides=('radare2-cutter') backup=() -source+=("${pkgname}::git+https://github.com/radareorg/r2cutter.git${_fragment}" - "cutter-translations::git+https://github.com/radareorg/cutter-translations") +source+=("${pkgname}::git+https://github.com/radareorg/iaito.git${_fragment}" + "iaito-translations::git+https://github.com/radareorg/iaito-translations") md5sums+=('SKIP' 'SKIP') @@ -36,12 +35,11 @@ pkgver() { prepare() { cd ${pkgname} - git config submodule.src/translations.url "${srcdir}"/cutter-translations - ((DISABLE_BUNDLED_RADARE)) && { - git submodule update --init --recursive "${submodules[@]}" src/translations - } || { + git config submodule.src/translations.url "${srcdir}"/iaito-translations + git submodule update --init --recursive "${submodules[@]}" src/translations + ((DISABLE_BUNDLED_RADARE)) || { git config submodule.radare2.url "${srcdir}"/radare2 - git submodule update --init --recursive "${submodules[@]}" + git submodule update --init --recursive "${submodules[@]}" radare2 } } @@ -49,11 +47,11 @@ build() { _CMAKE_FLAGS+=( -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=None - -DCUTTER_ENABLE_PYTHON=ON - -DCUTTER_ENABLE_PYTHON_BINDINGS=ON - -DCUTTER_USE_ADDITIONAL_RADARE2_PATHS=OFF - -DCUTTER_ENABLE_CRASH_REPORTS=OFF - -DCUTTER_ENABLE_GRAPHVIZ=ON + -DIAITO_ENABLE_PYTHON=ON + -DIAITO_ENABLE_PYTHON_BINDINGS=ON + -DIAITO_USE_ADDITIONAL_RADARE2_PATHS=OFF + -DIAITO_ENABLE_CRASH_REPORTS=OFF + -DIAITO_ENABLE_GRAPHVIZ=ON ) cmake -B build -S "${srcdir}/${pkgname}/src" "${_CMAKE_FLAGS[@]}" make -C build |