summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJSH2015-08-27 18:57:12 -0400
committerJSH2015-08-27 18:57:12 -0400
commitac59536533c8520ea978a98500e6f5d870777ee6 (patch)
tree399efd3fe131998d3373f7ae37415a61389cf115 /PKGBUILD
downloadaur-ac59536533c8520ea978a98500e6f5d870777ee6.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f8e3d201819
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: JSH <jsh6789(at)gmail(dot)com>
+# Contributor: Geoffroy Carrier <gcarrier@aur.archlinux.org>
+
+_pkgbase=r8101
+pkgname=r8101-dkms
+pkgver=1.027.00
+pkgrel=1
+pkgdesc="r8101 realtek lan drivers (DKMS)"
+arch=('i686' 'x86_64')
+url="http://realtek.com.tw/"
+license=('GPL2')
+depends=('dkms')
+optdepends=('ethtool: device configuration')
+provides=("${_pkgbase}")
+conflicts=("${_pkgbase}")
+install=${pkgname}.install
+
+# To retrieve the source file, you must first visit the following URL, click
+# the link to the right of the LINUX driver, and finally place the file in the
+# directory containing this PKGBUILD. Make sure the version matches pkgver.
+# http://www.realtek.com.tw/Downloads/downloadsView.aspx?Langid=1&PNid=14&PFid=7&Level=5&Conn=4&DownTypeID=3&GetDown=false
+
+source=('dkms.conf')
+
+package() {
+
+ # Copy dkms.conf
+ install -Dm644 dkms.conf "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
+
+ # Set name and version
+ sed -e "s/@_PKGBASE@/${_pkgbase}/" \
+ -e "s/@PKGVER@/${pkgver}/" \
+ -i "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
+
+ # Copy sources (including Makefile)
+ cp -r ${_pkgbase}-${pkgver}/src ${_pkgbase}-${pkgver}/Makefile \
+ "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/
+}
+sha256sums=('2846e89fe3fd68c64c71a0f1150873a061571acc63e65cca6d825df7985ad7b5')